
Kölnis üveg           
 

Ebben a feladatban négyféle felületszerkesztés szerepel. Az 
üveg negyed részét határoló görbéivel definiált spline-
felületként szerkesztjük, amelyet majd a szimmetriasíkokra 
tükrözünk. Az üveg alja vonalfelületként, a zárókupak pedig 
forgásfelületként készül. Végül görbehálóra illeszkedı 
felületként újraszerkesztjük az üveg testét, hogy az illesztések 
mentén sima legyen a csatlakozás. 
 
Beállítások: 
 
Az alapbeállításban a képmezı alatt jobb oldalon vannak a 
nézetre és a koordinátarendszerre vonatkozó parancsok ikonjai:  
DispView, CP=DV, CPlane, World/Cplane, 2D/3D, 

ConstructionDepth 

 
 
Világkoordinátákban dolgozunk: a World/Cplane ikonra (balról a negyedik) kattintva 
váltunk a világ 3-dimenziós és a képernyı 2-dimenziós koordinátarendszere között. Válasszuk 
azt az állást, amikor az ikonsor alatti kiírások között a WLD jelenik meg. Mellette a 2D/3D 
szerkesztési mód ikonjára kattintva a 3D beállítást válasszuk.  
A képernyın 4 ablakot definiálunk a menüsorból a Window > Split parancsokkal. Az egérrel 
helyezzük el az ablakokat elválasztó vonalakat középre.  
Minden parancsból az [Esc] billentyővel lépünk ki. 

A négy ablakban egyenként beállítjuk a nézet irányát. 
Az ikonsorban a DispView (balról az elsı) ikonra kattintunk, majd a bal felsı ablakban a 6-os 
oldalnézetet (yz koordinátasík), újra DispView, jobbra fent a 2-es elölnézetet (xz 
koordinátasík), balra lent a 7-es axonometrikus vetületet és jobbra lent a 4-es felülnézetet (xy 
koordinátasík) választjuk. A szerkesztés közben bármelyik ablakban kiválaszthatjuk a 
szükséges rajzelemeket. 
 
Segédvonalak:  
A vonalak színe piros (a Color ikonnal választható). 
Egyenes szakaszokat rajzolunk a 
koordináta-tengelyeken:  
Create > Line > EndPoints > KeyIn 
paranccsal a kezdıpont és végpont 3 
koordinátáját adjuk meg az X, Y, Z 
szövegmezıkben. Minden beírt 

számadat után nyomjuk le az [enter] 

billentyőt! 
Az x tengelyen: (-35,0,0), (35,0,0), 

y tengelyen (0,-15,0), (0,15,0), 
 z tengelyen (0,0,0), (0,0,120), [Esc] 
 



A pontok megadásánál válasszuk ki a megfelelı beállítást, azt ne hagyjuk a Cursor opción! 

A rajzelemeket célszerő különbözı rajzszinteken (level) csoportosítani.  
Ha már létrehozott rajzelemet (Entity) akarunk törölni, nyomjuk le egyszerre a Ctrl – Q 

billentyőket, Single beállítással mutassunk rá a törlendı elemekre, Accept, enter, Esc. Ezzel a 

gyorsbillentyővel szerkesztési folyamatban is törölhetünk. Az Esc csak a törlést fejezi be, és a 

rendszer visszatér a félbeszakított parancshoz. 

Az Autoscale paranccsal (a menü ikonsorában egy nagyító ábrázolja) az egyes ablakokban 
megjelenı vetületeket az ablak méretéhez igazítjuk. 
Amit eddig létrehoztunk, az mind az 1. rajzszinten van. A rajzmezı feletti ikonsorban 
kattintsunk a ToggleSplitter (sok kis lapot mutató) ikonra. A megjelenı listában jobb egérrel 
kattintsunk az egyelıre névtelen rajzszint sorára, és adjunk neki nevet (koordináta tengelyek). 
A lista fejlécében rajzolt kockára jobb egérrel kattintva CreateLevel paranccsal új rajzszintet 
hozunk létre, ez lesz a 2. számú, adjunk neki nevet (segédgörbék). Mivel most ez aktív, az 
újonnan definiált rajzelemek ide kerülnek. A táblázatot a ToggleSplitter ikonra való 
kattintással zárjuk be. 
 
Az üveg negyedrészét alkotó felület határoló görbéi: 
  
Negyed kör a felsı peremhez: 
A 2-dimenziós alakzatok a beállított szerkesztési síkban (Cplane) 

készülnek. 

A Cplane (balról a 3.) ikonra kattintva adjuk meg az xy síkot, az 1 
szám beírásával. (A szerkesztési sík kijelölése a megfelelı nézetben 

való szerkesztéssel is lehetséges a CP=DV állapotban, ha a 

megfelelı nézetet még a parancs kiadása elıtt kiválasztjuk!) 
Create > Arc > Ctr-Rad paranccsal megadjuk a körív sugarát: 10, 
a szögtartományt: 0-tól 90-ig a középpontját KeyIn beállítással: 
(0,0,120). 
 
Negyed ellipszis az alsó peremhez:  
Create > Conic > Ellipse values: fél nagytengely: 35, fél 
kistengely: 15, elforgatás szöge: 0, szögtartomány: 0-tól 90-ig, 
középpont az origó KeyIn: (0,0,0). 
A pont megadásának módja most EndEnt (rajzelem végpontja) is lehetett volna úgy, hogy a z 
tengely alsó végpontjára kattintunk.  
 
Segédpontok az oldalgörbékhez: 
Create > Point > Position > KeyIn: (0,20,80), 

(50,0,80). 
 
A felületfolt oldalgörbéi: 
Az yz síkban 3 pontra 3-ad fokú spline görbét illesztünk.  
3-dimenziós adatokkal adjuk meg a görbeívet, ilyenkor 
a Cplane beállításnak nincs szerepe, de átválthatjuk.  
Az yz síkra helyezett szerkesztési sík száma: Cplane=6. 
Create > Spline (I)> Spline 3D Cubic. A 3 
interpolációs pont a negyed ellipszis yz síkban lévı 
végpontja EndEnt megfogással, a (0,20,80) koordinátájú 
pont Point megfogással és a negyed kör yz síkban fekvı 
végpontja EndEnt megfogással, Done. A 



peremfeltételek lent (start condition) Natural, fent (end condition) Tangent, az érintı vektor 
koordinátáit numerikusan (KeyIn) adjuk meg: (0,0,1). [Esc] 
 
Az xz síkban (Cplane=2) ugyanígy adjuk meg a másik peremgörbét. Create > Spline (I) > 

Spline 3D Cubic, a 3 pontot adjuk meg: a negyed ellipszis xz síkban fekvı végpontja 
(EndEnt), az (50,0,80) pont (Point) és a negyed kör megfelelı végpontja (EndEnt), Done. A 
peremfeltételek sart condition: Natural, end condition Tangent, (0,0,1). [Esc]. 
 
Felületdefiniálás: 
Válasszunk új színt (Color). 
Válasszunk új rajzszintet: ToggleSplitter, kattintsunk jobb egérrel a fejlécben a kis kockára, 
adjunk nevet a rajzszintnek (oldalfelület), ez lesz az aktuális level, ToggleSplitter. 
Advanced modelling Create > Surface > Edge curve. A definiáló ablakban válasszuk a 
spline surface és Four edges beállításokat. OK. Sorban rámutatunk a 4 csatlakozó 
peremgörbére, Accept, [Esc].  A késıbbi szerkesztés szempontjábóla görbék megadását  
célszerő az ellipszisívvel kezdeni. 
Figyeljük meg, hogy a felületi normális kifelé mutat-e: Tools > Extract > Face Data > 

Normal. SelectFace, a felületre mutatunk. A felület normálisa megfordítható az Advanced 

Modeling > Modify > Modify normals paranccsal. A láthatóság miatt fontos, hogy a 
normális kifelé mutasson. 
 
Az egész felület elkészítése tükrözésekkel: 
Dolgozzunk tovább egy ablakban: View > Viewport Layout >Single;  
DispView = 7. 
XForm > Mirror > Copy , Single kiválasztással a spline felületre mutatunk, choose 
ADDITION [enter], a tükrözési síkot Plane beállítással pl. 3Pos opcióval az x tengely 2 
végpontjára (EndEnt) és a z tengely felsı végpontjára kattintással adjuk meg. 
Ugyanígy tükrözünk az yz síkra is, majd ezt a negyedet ismét az xz síkra tükrözzük. 
A teljes felületet kiszínezve a View > Render > Gouraud rendering paranccsal nézzük meg. 
Az elkészült felület az illesztések mentén nem sima, mivel a peremgörbék mentén az érintıket 
nem tudtuk befolyásolni.   
Ezután térjünk vissza a drótvázas ábrázoláshoz: View > Render > Wireframe. 
 
Az üveg aljának és kupakjának 
szerkesztéséhez szükséges segédgörbék:  
Új rajzszintet definiálunk a segédgörbék 
számára a ToggleSplitter táblázatban. 
Kapcsoljuk ki a spline felület rajzszintjét a 
Disp oszlopban a pipa jelre kattintva. 
Választhatunk új vonalszínt is (Color). 
A fenékfelület az alapellipszis és egy pont 
által definiált vonalfelület, azaz elliptikus 
kúp lesz. 
 
A kupak forgásfelület lesz. Ennek készítsük 
el az xz síkban a meridián görbéjét: generator 
curve. Ez 3 darabból áll. Függıleges szakasz: 
Create > Line > Endpoints, KeyIn, 

(10,0,120), (10,0,130). 



Fél ellipszis: Create > Ellipse > Ellipse Values, 15, 5, 0, -90, 90, (10,0,135). 
Vízszintes szakasz: Create > Line > EndPoints, (10,0,140), (0,0,140). 

 
A fenékfelület és kupak: 
Az új felületeket új rajzszinten definiáljuk a ToggleSplitter táblázatának segítségével. 
 
A fenékfelület:  
Advanced Modeling > Create Surface > Ruled > Curve and a point. A definiáló 
táblázatban CurveFit, Chain Select the Curves beállítások után mutassunk sorban a 
felületeket határoló negyed ellipszisekre,  Accept. A select ruling position felszólításra KeyIn 
beállítással a (0,0,20) koordinátájú pontot adjuk meg. 
 
A kupak: 
z tengelyő forgásfelület lesz: Advanced Modeling > Create Surface > Srf of rev.. A 
táblázatban Start angle 0, End angle 360, Spline surface beálítások után Axis of rotation, 
Line, mutassunk a z tengelyre,  generator curve: mutassunk a 3 megrajzolt meridián görbére 
(függıleges szakasz, ellipszis ív, vízszintes szakasz). 
 
Kapcsoljuk ki a segédvonalakat tartalmazó rajzszinteket, és kapcsoljuk be az oldalfelületeket, 
az alját és a kupakot (ToggleSplitter táblázat Disp oszlopában), majd nézzük meg a teljes 
kölnis üveget a View > Render >Gouraud shading paranccsal. 
 
A modellt dinamikusan forgathatjuk a felsı menüsorban található forgó kockát mutató 
ikonnal (spin). Itt egy forgásközéppontot kell megadni, amihez kivételesen használhatjuk a 
Cursor opciót, majd az egérrel a modell tetszıleges pontját megfogva változtatjuk a vetítési 
irányt. 
 
Simítás az illesztések mentén: 
 
Advanced Modeling > Modify > Surface > Match 
NURBS Surface Edges > (Combine Surfaces 
together) > Matching on the common subset of 
edges > Averaging both surfaces: két szomszédos 
felületre, majd az összeérı hálógörbék irány-
vektoraira mutatunk. 
 
Mind a laposabb mind az éles illeszkedésnél a 
rendszer elsimítja az éleket. 
 
Simítás más módon: adott végérintıkkel definiált 
görbesereg szerkesztésével. 
 
A negyed felület újradefiniálása 
 
Kapcsoljuk be a negyed felületet tartalmazó rajzszintet, majd definiáljunk egy új rajzszintet, 
amelyen új segédgörbéket fogunk szerkeszteni. 
Erre az üres rajzszintre átmásoljuk a negyed felületet: XForm > Delta(X) > Copy > Single, 
mutassunk a felületre, Accept, enter, number of copies 1, Accept, Indicate delta values: dx 0, 
enter,  dy 0, enter, dz 0, enter. Esc. Most a kiválasztott rajzelem az aktív rajzszintre 
másolódott.  



Lekérdezzük a negyed ellipszis érintıvektorait a kezdı- és végpontjában: Advanced 

Modeling > Tools > Solid Tools Extract , a lekérdezhetı adatok táblázatában kapcsoljuk be 
az Uflow lines, Tangent adatokat, majd a felület kiválasztása után EndEnt beállítással 
mutassunk az alsó peremgörbe két végpontjára. Megjelenik a negyed ellipszis két végérintıje. 
(Az, hogy a felületnek mely görbéi az u, ill. v paramétervonalai, az attól függ, hogy a felület 

definiálásakor milyen sorrendben mutattuk meg a 4 határoló görbét. Amennyiben a hosszanti 

görbék érintı vektorai jelentek meg, akkor az adatok táblázatában a Vflow lines és Cross 

vektor adatokat kell bejelölni.) 
 
A segédgörbék elkészítése 
Készítsünk segédpontokat az egyik hosszanti spline görbén: Create > Point > Point number, 
Enter number of segments on curve, 4, Accept, mutassunk a görbére. Ezeken a pontokon át u 
paramétervonalakat (ill. az adott helyzetnek megfelelıen v paramétervonalakat) készítünk:  
Advanced Modeling Tools > Solid Tools Extract, Uflow lines megadással, Point 

beállítással mutassunk az elkészített pontokra. Ezeknek a felületi görbéknek a végpontjaiba 
eltoljuk a negyed ellipszis érintıvektorait. XForm > XForm Old-New (W) > XForm OTN 

Full Copy, Single opcióval kiválasztjuk az ellipszis érintıt, Accept, number of copies 1,  base 
position a vektor kezdıpontja, Skip,  New base position, EndEnt beállítással a 3 felületi 
görbe megfelelı végpontjára mutatunk. A másik ellipszis érintıt ugyanígy eltoljuk a felületi 
görbék megfelelı végpontjaiba. (A felületi görbék nem simulnak ezekhez az érintıkhöz, 
emiatt látszik törésvonal a szomszédos felületfoltok között.) 
Válasszunk új színt! 
A 3 közbülsı helyen új spline görbéket készítünk két végponttal és végérintıkkel: Create 

spline > Spline 3D cubic > EndEnt,  
mutassunk az egyik felületi görbe két 
végpontjára, Done, majd TwoPts beállítással 
a megfelelı érintıvektor kezdı- és 
végpontját adjuk meg (EndEnt) a start 
pozícióban, a vektor hossza (magnitude) 
legyen 1. Hasonlóan járunk el az end 
pozícióban is.  
 
Görbehálóra illesztett felület definiálása 
Adjunk meg új rajzszintet. Advanced 

Modeling > Create > Create Surfaces > 

Curve mesh srf, a táblázatban CurveFit, 
Spline surface választás után, Select 

PRIMARY curve No1, mutassunk a negyed 
ellipszisre, sorban az új 3 spline görbére, majd a körívre, Accept, Select SECONDARY 

curve, mutassunk a 2 hosszanti spline görbére, Accept. 
A most elkészült felületfoltot tükrözzük az xz és yz szimmetriasíkokra. (Ehhez kapcsoljuk be 
a segédvonalak rajzszintjét).  
Az illeszkedés simaságának ellenörzése 
Lekérdezzük a felületi normálisokat a csatlakozó görbék mentén, pl. a középpontjukban. 
Advanced Modeling > Tools > Solid Tools Extract, Normals adatot válasszunk a 
táblázatban, válasszuk ki az egyik negyed felületet, majd Ctr/Mid beállítással mutassunk a 
hosszanti határoló spline görbe felezıpontjára. Ugyanezt ismételjük meg a szomszédos 
negyed felületre. A két felületi normális látszatra egybeesik. Az eltérést megállapíthatjuk, ha 
lekérdezzük az általuk bezárt szöget: a menüsorból válasszuk a Tools > Verify > Angle 
parancsokat, és mutassunk rá a két normálvektorra. Az ábrán látható  felületen ez a szög 0 fok 



20 perc a laposabb csatlakozásnál, és 0 fok 31 perc az élesebb csatlakozásnál. A felület ezzel 
a szerkesztéssel simább is és szebb is lett. Az üveg gömbölyőségét lényegesen befolyásolja 
az, hogy milyen hosszú érintıvektorokat adtunk meg a szerkesztett segédgörbék 
végpontjaiban. A megfelelı (magnitude) érték csak kísérletezéssel állapítható meg, hiszen a 
felületek matematikai leírását nem ismerjük. 

 
 

 

    
 
 
 
 
 
 
 
 
 
 
 
 


